Bug #44139

UriBuilder includes all arguments of namespaced sub request

Added by Aske Ertmann about 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
MVC - Routing
Start date:
2012-12-19
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Yes
Complexity:
medium

Description

When creating a link in a sub request using argument namespace the arguments of the current sub request is added to all links even though addQueryString is not set. This happens because the logic removing them were removed when fixing #42770. The problem is that fix removes the current arguments for sub requests correctly, but when the arguments of the parent request are added it adds those namespaced arguments which actually belong to the sub request again.


Related issues

Related to TYPO3.Flow - Bug #42770: Routing includes parameters from the current requestResolved2012-11-07

Actions
#1

Updated by Aske Ertmann about 8 years ago

  • Subject changed from UriBuilder includes arguments from parent request to UriBuilder includes all arguments of namespaced sub request
#2

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch 2.0 has been pushed to the review server.
It is available at https://review.typo3.org/17663

#3

Updated by Karsten Dambekalns over 7 years ago

  • Target version changed from 2.0 to 2.0.1
#4

Updated by Aske Ertmann over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF