Bug #44280

Git core:migration check for applied version fail

Added by Tarcisio Fedrizzi about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Should have
Category:
- Migrations -
Start date:
2013-01-03
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Yes
Complexity:
no-brainer

Description

When I migrate a package for the changes introduced in the code I get the following error:

Applying TYPO3.FLOW3-201201261636
fatal: Invalid object name 'Migration'.
  Migrating Package.Name
    No changes were committed.

  -------------------------------------------------------------------------------
   Notes
  -------------------------------------------------------------------------------
  * \TYPO3\FLOW3\MVC\Web\RequestBuilder does not exist anymore. If you need to
    create requests, do "new ActionRequest($parentRequest)".
...

I tracked down the problem to the migration script Git.php. The problem is in the
grep parameter specified without the = operator.
The attached patch solves the problem.

Files

migration-applied-check.patch (675 Bytes) migration-applied-check.patch Tarcisio Fedrizzi, 2013-01-03 11:07
#1

Updated by Karsten Dambekalns about 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Karsten Dambekalns

What Git version are you using? And under what OS/shell combination?

#2

Updated by Tarcisio Fedrizzi about 8 years ago

Here are the info:
- GIT version: 1.7.2.5
- OS: Debian Squeeze 6.0
- Shell: /bin/bash version 4.1.5

About the grep option the manpage for git says:

--grep=<pattern>
           Limit the commits output to ones with log message that matches the specified pattern (regular expression).

I've checked more recent version (1.8.1) manpage and the value for the grep option is still specified to be used with the = operator.

#3

Updated by Karsten Dambekalns about 8 years ago

  • Status changed from Needs Feedback to Accepted
  • Target version set to 2.0
#4

Updated by Karsten Dambekalns about 8 years ago

  • Status changed from Accepted to Under Review
#5

Updated by Karsten Dambekalns about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF