Task #44400

ContenElementWrappingService needs safeguard for date unserialization

Added by Robert Lemke over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
UI
Start date:
2013-01-09
Due date:
% Done:

100%


Description

The service only checks if a date-typed node property is != NULL, but doesn't check if it is actually a DateTime object. In some cases, the property might be an empty string or ... whatever. These edge cases should at least not end with a fatal error.

Associated revisions

Revision 73ebcb5e (diff)
Added by Robert Lemke over 6 years ago

[TASK] Additional check for date properties

This adds another check to make sure that corrupt or unexpected values
of date node properties don't lead to a fatal error caused by calling
methods on a non-object.

Change-Id: Ie53c83b7abd3ceaa76dcecc604238126af27cb4f
Resolves: #44400

History

#1 Updated by Robert Lemke over 6 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF