Feature #44572

Format.Case ViewHelper in order to change the case of string values

Added by Adrian Föder almost 9 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Could have
Assignee:
Category:
ViewHelpers
Target version:
-
Start date:
2013-01-16
Due date:
% Done:

100%

Estimated time:
Has patch:
No

Description

Have an f:format.case ViewHelper with the options "lower", "upper" and "capital" which results into strtolower, strtoupper, and ucfirst.


Related issues

Related to TYPO3 Core - Feature #58621: Format.Case ViewHelper in order to change the case of string valuesClosedAlexander Schnitzler2014-05-08

Actions
Is duplicate of TYPO3.Fluid - Feature #27091: Viewhelpers for strtolower/strtoupperClosed2011-05-27

Actions
#1

Updated by Adrian Föder almost 9 years ago

  • Status changed from Accepted to Under Review
#2

Updated by Gerrit Code Review over 8 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17564

#3

Updated by Adrian Föder over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Bastian Waidelich over 8 years ago

FYI: I just added a test case for this View helper to the Viewhelpertest package: https://review.typo3.org/#/c/20671/

#5

Updated by Robert Wildling over 8 years ago

It does not seem to be resolved, unless I am misunderstanding something here.
The namespaces is wrong, if used with TYPO3 CMS 6: at the moment it is

namespace TYPO3\Fluid\ViewHelpers\Format;

but should be:

namespace TYPO3\CMS\Fluid\ViewHelpers\Format;

(with the "CMS\")

This is also true for the class definition.

Please correct me, if my comment here is in a wrong context. Thanks!

#6

Updated by Michael Christian almost 8 years ago

  • Status changed from Resolved to New
  • % Done changed from 100 to 40

Can't find "CaseViewHelper.php" in "typo3_src-6.2.0alpha2".
Please add the ViewHelper to V6.2.0.
Thank you!

#7

Updated by Bjoern Jacob almost 8 years ago

Will this be part of TYPO3 6.2?

#8

Updated by Adrian Föder over 7 years ago

  • Status changed from New to Resolved

Robert, Michael and Bjoern: could you please, if any, open an issue at http://forge.typo3.org/projects/typo3v4-fluid and point to this one? This thread is for TYPO3 Flow's Fluid.

#9

Updated by Bjoern Jacob over 7 years ago

  • % Done changed from 40 to 100

Thx for your reply. Created ticket #58621. Since this is resolved in Fluid I change back done to 100%.

Also available in: Atom PDF