Bug #45072

Possible error with git submodules

Added by Sven Radetzky almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Target version:
-
Start date:
2013-02-01
Due date:
% Done:

0%

Estimated time:

Description

The first thing i wanna say is that i am not 100 percent sure that this is a Surf Bug. But i get this rather interesting error while running Surf with my current project.

Deploying demo.seite.de (20130201132902)
Using workflow "Simple workflow" 
Stage initialize
Node demo.seite
Application projekt
Executing stage "initialize" on "demo.seite" for application projekt
demo.seite (projekt) typo3.surf:createdirectories
$demo.seite: "test -d www/demo.seite.de" 
$demo.seite: "mkdir -p www/demo.seite.de/releases;mkdir -p www/demo.seite.de/shared;mkdir -p www/demo.seite.de/releases/20130201132902;cd www/demo.seite.de/releases;ln -snf ./20130201132902 next" 
Task "typo3.surf:generic:createDirectories" after "typo3.surf:createdirectories" for application projekt
demo.seite (projekt) typo3.surf:generic:createDirectories
demo.seite (projekt) typo3.surf:typo3:flow:createdirectories
$demo.seite: "mkdir -p www/demo.seite.de/shared/Data/Logs;mkdir -p www/demo.seite.de/shared/Data/Persistent;mkdir -p www/demo.seite.de/shared/Configuration" 
Stage update
Node demo.seite
Application projekt
Executing stage "update" on "demo.seite" for application projekt
demo.seite (projekt) typo3.surf:gitcheckout
$demo.seite: "git ls-remote ssh://git@bitbucket.org/firma/projekt/ refs/heads/master | awk '{print $1 }'" 
    > 4ff99ac790d3275bceb0c4b645b8038e49459b4c
$demo.seite: "if [ -d www/demo.seite.de/cache/localgitclone ];     then      cd www/demo.seite.de/cache/localgitclone      && git fetch -q origin      && git reset -q --hard 4ff99ac790d3275bceb0c4b645b8038e49459b4c      && git submodule -q init      && for mod in `git submodule status | awk '{ print $2 }'`; do git config -f .git/config submodule.${mod}.url `git config -f .gitmodules --get submodule.${mod}.url` && echo synced $mod; done      && git submodule -q sync      && git submodule -q update --init --recursive      && git clean -q -d -x -ff;     else      git clone -q ssh://git@bitbucket.org/firma/projekt/ www/demo.seite.de/cache/localgitclone      && cd www/demo.seite.de/cache/localgitclone      && git checkout -q -b deploy 4ff99ac790d3275bceb0c4b645b8038e49459b4c      && git submodule -q init      && git submodule -q sync      && git submodule -q update --init --recursive;    fi" 
    > No submodule mapping found in .gitmodules for path 'Packages/Application/TYPO3.Form'
No submodule mapping found in .gitmodules for path 'Packages/Application/TYPO3.Form'
Got exception "Command returned non-zero return code: 1" rolling back.
Rolling back TYPO3\Surf\Task\TYPO3\Flow\CreateDirectoriesTask
Rolling back TYPO3\Surf\Task\Generic\CreateDirectoriesTask
Rolling back TYPO3\Surf\Task\CreateDirectoriesTask
$demo.seite: "rm www/demo.seite.de/releases/next;rm -rf www/demo.seite.de/releases/20130201132902" 

So either it's an error in TYPO3.Surf or in TYPO3.Form, really not sure which though.

#1

Updated by Martin Lipp over 8 years ago

I'm guessing you simply cloned TYPO3.Form from git into your project. You have to either delete the .git directory inside TYPO3.Form (loosing the possibility to pull updates) or clone it as a submodule [1] (which allows repositories inside other repositories). So it's not a bug.

[1] http://git-scm.com/book/en/Git-Tools-Submodules

#2

Updated by Tobias Liebig over 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF