Bug #46038

Subproperty with Radio fields doesn't render hidden identity property

Added by Christian Müller over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Category:
ViewHelpers
Target version:
-
Start date:
2013-03-05
Due date:
% Done:

0%

Estimated time:
Has patch:
No

Description

If you render a form and access a property in a subpobject in your forms bound object via radio input field there are no hidden identity fields rendered as the radio input expects a value to be set in addition to the property which in turn prevents the addAdditionalIdentityPropertiesIfNeeded() to be called ever.


Related issues

Is duplicate of TYPO3.Fluid - Bug #29290: Additional Identity Properties not set on mapping errorResolvedBastian Waidelich2011-08-26

Actions
Is duplicate of TYPO3.Fluid - Bug #45184: Additional identity filed are not rendered, after validation errorClosedBastian Waidelich2013-02-05

Actions
#1

Updated by Benno Weinzierl over 8 years ago

I am having a somewhat similar problem when an validation-error occurs.
In this case $this->addAdditionalIdentityPropertiesIfNeeded(); is also not called (in \TYPO3\Fluid\ViewHelpers\Form\AbstractFormFieldViewHelper in Method getValue() ).

Why is it not called? Was this simply forgotten or is there a reason for not calling $this->addAdditionalIdentityPropertiesIfNeeded() in these two cases?

I added the method call for the error-case, but then in my create-Form i get the error:
#1243325768: No value found for key "TYPO3\Fluid\ViewHelpers\FormViewHelper->formObject"

So this needs a bit more knowledge of the Fluid internals...

#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19275

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19276

#4

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19279

#5

Updated by Bastian Waidelich over 8 years ago

  • Category set to ViewHelpers
  • Status changed from Under Review to Closed
  • Assignee set to Bastian Waidelich

Closing as duplicate of #29290 and #45184 – I'll take care of this now

Also available in: Atom PDF