Bug #46630

Submodules doesn't support linking to a different controller

Added by Soren Malling over 6 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-03-24
Due date:
% Done:

0%


Description

While trying to do a simple concept implementation of TYPO3.FormBuilder I found out, that links with a "Controller" argument isn't supported. The "Controller" argument isn't respected, and the link points to the registred (in Settings.yaml) controller

History

#1 Updated by Soren Malling over 6 years ago

From my research, it's about either extending the Routes configuration for modules URI or extending the BackendModuleArgumentsRoutePartHandler class

Any hints on this?

#2 Updated by Aske Ertmann over 6 years ago

  • Status changed from New to Rejected

AFAIK it's only supported using regular links within the same module controller. If you need to jump to another controller it has to be registered as a module and the link module view helper, another solution is to use sub requests like it's done in Expose.

I'm rejecting this for now since it's not a bug, but as intended at least for the time being.

Also available in: Atom PDF