Bug #47743

Error if local extension depends on another local extension

Added by Chris Müller over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2013-04-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you have a local extension which is not available from TER und declare a dependency to another local extension (also not available from TER) you got an error:

"The extension xxx is not available from TER."

So it is not possible to declare a dependency between local extensions.

TYPO3 version: 6.1rc1


Related issues

Is duplicate of TYPO3 Core - Bug #56380: The extension xxx is not available from TER. But its already installed!!Closed2014-02-27

Actions
#1

Updated by Chris Müller over 8 years ago

It seems that this error occurs, if the version of the other local extension matches not the condition.

Example:
Local Extension A has version 1.2.0 and is installed on the system.

Local Extension B depends on Extension A but requests version 1.3.0.

If you install Extension B, the error "The extension xxx is not available from TER." is thrown. The error message is wrong.

#2

Updated by Mathias Schreiber almost 7 years ago

  • Is Regression set to No

Taken into account in #63909.
The issues are not linked on purpose, so the refactoring ticket does not get bloated with relations.

#3

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF