Bug #48121

TextareaViewHelper is missing valid html5 argument placeholder ...

Added by Helmut Hummel over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
ViewHelpers
Start date:
2013-05-12
Due date:
% Done:

100%

Estimated time:
Has patch:
Yes

Description

TextareaViewHelper is missing valid html5 argument placeholder ...

Using

            <f:form.textfield id="powermail_field_{field.marker}" placeholder="{field.title -> vh:string.RawAndRemoveXss()}" name="field[{field.uid}]" value="{vh:Misc.PrefillField(field: '{field}')}" class="powermail_field powermail_input {vh:Misc.ValidationClass(field: '{field}')} {vh:Misc.ErrorClass(field: '{field}', class: 'powermail_field_error')}" required="{field.mandatory}" />

with the attribute placeholder causes the exception http://typo3.org/go/exception/v4/1237823695 , what means, that the argument placeholder is not allowed.


Related issues

Related to TYPO3.Fluid - Feature #55723: Support of schema.org attributesClosedBastian Waidelich2014-02-06

Actions
Is duplicate of TYPO3.Fluid - Task #37558: Form.Textfield ViewHelper's placeholder attribute should be (re)movedResolvedKarsten Dambekalns2012-05-29

Actions
#1

Updated by Helmut Hummel over 8 years ago

Corresponding ticket in TYPO3 CMS tracker #45960

#2

Updated by Alexander Berl over 8 years ago

You should use the additionalAttributes attribute for things like that.

 <f:form.textfield ... additionalAttributes="{ placeholder: field.title -> vh:string.RawAndRemoveXss() }" />

#3

Updated by Bastian Waidelich over 8 years ago

Alexander Berl wrote:

You should use the additionalAttributes attribute for things like that.

Right, this is a work around. But I agree that we should make common HTML5 attributes available in the form View Helpers for convenience

#4

Updated by Philipp Maier over 8 years ago

  • % Done changed from 0 to 100

This is fixed. Just tested it today with current master.

#5

Updated by Adrian Föder over 8 years ago

right Philipp, it's solved with I24bb73c5de5a494259171ff289d434892f85e16e on Jan 24; however I wonder why this issue is that "fresh", Helmut, is your inquiry based on an older state?

#6

Updated by Adrian Föder over 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF