Task #48146

Work Package #45020: Content Editing Stability and Features

Change default generated node paths when changing the node title

Added by Aske Ertmann over 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2013-05-13
Due date:
% Done:

80%

Estimated time:

Description

A default node path is generated when creating a new node, we should change this automatically when a node with a title property is changed if it still has the default node path. This is to make it easier for the editor to get nice URL's. For now we should however not change this automatically if the title changes and the node path is not a generated one, because we lack a good way to support redirects from old URL's.

#1

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20763

#2

Updated by Aske Ertmann over 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Aske Ertmann
  • % Done changed from 0 to 80
#3

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20846

#4

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20846

#5

Updated by Sebastian Kurfuerst over 8 years ago

  • Status changed from Accepted to Under Review
#6

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20763

#7

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20763

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20763

#9

Updated by Aske Ertmann over 8 years ago

  • Target version set to 1.0 beta 1
#10

Updated by Aske Ertmann over 8 years ago

  • Target version changed from 1.0 beta 1 to 1.0 alpha 6
#11

Updated by Robert Lemke about 8 years ago

  • Status changed from Under Review to Closed

Closing this issue because it's a duplicate of #44644 - I'll comment on your patch in Gerrit, too

#12

Updated by Aske Ertmann about 7 years ago

  • translation missing: en.field_remaining_hours set to 0.0

Also available in: Atom PDF