Task #48312

Check existing pages about licensing and correct misleading allegations

Added by Jo Hasenau about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Target version:
Start date:
2013-05-16
Due date:
% Done:

90%

Estimated time:

Description

While checking the license for another issue, I have found the following statement on the official page about TYPO3 licensing, which is IMHO completely wrong:

Extensions are essentially modifications of the original source code and therefore
still fall under the GNU General Public License version 2. 
This means you are not allowed to sell the Extension itself directly, 
but you can offer to write an Extension and get paid for providing that Service instead.

This is nowhere written in GPLv2 and IMHO just wrong, since you can sell any GPLed code for any price you like as long as you provide the sources and the license for your client. So any client who bought the extension would just have the rights granted by GPLv2. He could for example sell the extension as well or just give it away for free.

http://www.gnu.org/licenses/gpl-faq.html

Does the GPL allow me to sell copies of the program for money?

Yes, the GPL allows everyone to do this. 
The right to sell copies is part of the definition of free software. 
Except in one special situation, there is no limit on what price you can charge. 
(The one exception is the required written offer to provide source code that must accompany binary-only release.)

Related issues

Is duplicate of Board (public) - Support #48201: License TermsResolvedFrederic Gaus2013-05-15

Actions
#1

Updated by Olivier Dobberkau about 9 years ago

please see: https://forge.typo3.org/issues/48201 and close this one here. thanks!

#2

Updated by Olivier Dobberkau about 9 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Jo Hasenau
  • Target version set to Q2 2013
  • % Done changed from 0 to 90
#3

Updated by Jo Hasenau about 9 years ago

  • Status changed from Needs Feedback to Closed

Sorry - didn't check for related issues within the other trackers ;-)

#4

Updated by Olivier Dobberkau about 9 years ago

no problem. thats almost impossible to find if you dont follow all issues.

Also available in: Atom PDF