Feature #49305

Support for Data Attributes in tag-based ViewHelpers

Added by Marco Falkenberg over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Category:
ViewHelpers
Target version:
-
Start date:
2013-06-21
Due date:
% Done:

0%

Estimated time:
Has patch:
No

Description

Adding Data Attributes to tag-based ViewHelpers via "additionalAttributes" is an exhausting task, because of the escaping and nesting stuff and so on.

<f:link action="doSomething" data-role-tooltip="{f:translate(id:'doSomething')}">Do something!</f:link>

vs.

<f:link action="doSomething" additionlAttributes="{data-role-tooltip: '{f:translate(id:\'doSomething\')}'}">Do something!</f:link>

Related issues

Is duplicate of TYPO3.Fluid - Feature #35748: Add generic data-* attributeResolvedBastian Waidelich2012-04-06

Actions
#1

Updated by Marco Falkenberg over 8 years ago

Sorry, duplicate

#2

Updated by Bastian Waidelich over 8 years ago

  • Status changed from New to Closed
  • Assignee set to Bastian Waidelich

Closing as duplicate

Also available in: Atom PDF