Bug #49780

Roles are not synchronized

Added by Soren Malling over 6 years ago. Updated over 6 years ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Security
Target version:
-
Start date:
2013-07-08
Due date:
% Done:

0%

PHP Version:
Has patch:
No
Complexity:

Description

Issue occured trying to install TYPO3 Neos Alpha4

Installing with the instructions from neos.typo3.org/download.html, and following this command pattern

composer command + doctrine:migrate + site:import + user:create

I get the following error

➜  Neos git:(cd5105e) ./flow user:create --username sorenmalling --password YOURPASSWORD --first-name YOURFIRSTNAME --last-name YOURLASTNAME --roles "TYPO3.Neos:Administrator" 
The role with identifier "TYPO3.Neos:Administrator" is unknown
➜  Neos git:(cd5105e) ./flow user:create --username sorenmalling --password YOURPASSWORD --first-name YOURFIRSTNAME --last-name YOURLASTNAME                                  
The role with identifier "TYPO3.Neos:Editor" is unknown

After chatting with Rens we came to the conclusion that TYPO3.Neos Roles aren't synchornized with the rest of the Flow roles.

History

#1 Updated by Rens Admiraal over 6 years ago

  • Category set to Security

a workaround for this issue is force clearing the cache with

./flow flow:cache:flush --force

Tested if https://review.typo3.org/#/c/22061/ is actually present in the local install with given composer command, and it is. So the role synchronization should've been done directly after the doctrine:migrate command.

Also available in: Atom PDF