Bug #51082

Object Route Parts should take persistence_object_identifier into account

Added by Christian Müller about 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Should have
Category:
MVC - Routing
Target version:
-
Start date:
2013-08-15
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
No
Complexity:
easy

Description

If no uriPattern is set for a Object Route Part it defaults to the identity properties of the entity. It should also work to fallback to the persistence_object_identifier instead which doesn't happen atm but results in an exception.

#1

Updated by Bastian Waidelich about 8 years ago

FYI: This is how it used to be. The IdentityRoutePart uses ClassSchema::getIdentityProperties() to retrieve the properties that identify an entity. Apparently this does not work any longer if an object only uses the automagical persistence_object_identifier..

#2

Updated by Christian Müller about 8 years ago

  • Status changed from New to Accepted

Alright, so this is really a bug. I was not sure if the current behavior was intentional.

#3

Updated by Bastian Waidelich almost 8 years ago

  • Assignee set to Bastian Waidelich

I'm fixing this now

#4

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24490

#5

Updated by Bastian Waidelich almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 2.0 of project Packages/TYPO3.Flow has been pushed to the review server.
It is available at https://review.typo3.org/27729

#7

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch 2.0 of project Packages/TYPO3.Flow has been pushed to the review server.
It is available at https://review.typo3.org/27729

#8

Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch 2.0 of project Packages/TYPO3.Flow has been pushed to the review server.
It is available at https://review.typo3.org/27729

#9

Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch 2.0 of project Packages/TYPO3.Flow has been pushed to the review server.
It is available at https://review.typo3.org/27729

#10

Updated by Bastian Waidelich over 7 years ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF