Task #51187

Task #51183: CLI improvements

Add generic help switch for all commands

Added by Christopher Hlubek over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-08-19
Due date:
% Done:

0%

Estimated time:

Description

Right now the help for a command can be displayed with ./flow help routing:list

It would be convenient to get the help of a command also with a switch "--help" after specifying the command:

./flow routing:list --help

If the command declares a help argument the help should be handled by the command (this will be backwards compatible for most commands).


Related issues

Is duplicate of TYPO3.Flow - Task #42452: Command handling should support global flagsClosedBastian Waidelich2012-10-28

Actions

Also available in: Atom PDF