Bug #52216

TYPO3\Flow\Error\Exception thrown in file ErrorHandler.php

Added by Tansel Cubuk about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
Category:
- Error Handler Report -
Target version:
-
Start date:
2013-09-24
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

Warning: symlink(): Cannot create symlink, error code(1314) in E:\weblocal\flow1\Quickstart\Data\Temporary\Development\Cache\Code\Flow_Object_Classes\TYPO3_Flow_Resource_Publishing_FileSystemPublishingTarget.php line 116
21 TYPO3\Flow\Error\ErrorHandler::handleError(2, "symlink(): Cannot create symlink, error code(1314)", "E:\weblocal\flow1\Quickstart\Data\Temporary\Develo…Resource_Publishing_FileSystemPublishingTarget.php", 116, array|3|)

20 symlink("E:/weblocal/flow1/Quickstart/Packages/Framework/TYPO3.Flow/Resources/Public", "E:/weblocal/flow1/Quickstart/Web/_Resources/Static/Packages/TYPO3.Flow")

19 TYPO3\Flow\Resource\Publishing\FileSystemPublishingTarget_Original::publishStaticResources("E:/weblocal/flow1/Quickstart/Packages/Framework/TYPO3.Flow/Resources/Public/", "Packages/TYPO3.Flow/")

18 TYPO3\Flow\Resource\Publishing\ResourcePublisher_Original::publishStaticResources("E:/weblocal/flow1/Quickstart/Packages/Framework/TYPO3.Flow/Resources/Public/", "Packages/TYPO3.Flow/")

17 TYPO3\Flow\Resource\ResourceManager_Original::publishPublicPackageResources(array|19|)

16 TYPO3\Flow\Core\Booting\Scripts::initializeResources(TYPO3\Flow\Core\Bootstrap)

15 call_user_func(array|2|, TYPO3\Flow\Core\Bootstrap)

14 TYPO3\Flow\Core\Booting\Step::__invoke(TYPO3\Flow\Core\Bootstrap)

13 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

12 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

11 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

10 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

9 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

8 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

7 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

6 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

5 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

4 TYPO3\Flow\Core\Booting\Sequence::invoke(TYPO3\Flow\Core\Bootstrap)

3 TYPO3\Flow\Http\RequestHandler::boot()

2 TYPO3\Flow\Http\RequestHandler::handleRequest()

1 TYPO3\Flow\Core\Bootstrap::run()

Please include more helpful information!

#1

Updated by Adrian Föder about 8 years ago

  • Status changed from New to Closed
  • Assignee set to Tansel Cubuk

Hi Tansel, thanks for your feedback.
It's a common windows issue, see here: http://wiki.typo3.org/FLOW3_Installation_Hints#Symbolic_Links

If you still encounter problems feel free to join the IRC channel or the Mailing List (or reopen the issue).

Best,
Adrian

Also available in: Atom PDF