Bug #52888

FIRST_INSTALL file is ignored

Added by Mathias Brodala about 6 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2013-10-16
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The FIRST_INSTALL file which may be used to have the TYPO3 installer automatically create the ENABLE_INSTALL_TOOL file is completely ignored in the new installer. In fact, a file search yields nothing.

History

#1 Updated by Markus Klein about 6 years ago

  • Status changed from New to Needs Feedback

This mechanism is not necessary anymore since on first install the install tool is accessed directly.

You can try it by simply unpacking the source and creating the symlinks for typo3_src, typo3 and index.php

The install tool shall popup without the need of creating the ENABLE_INSTALL_TOOL file.

#2 Updated by Mathias Brodala about 6 years ago

If I do that, all is get is the usual "locked" message. This also makes sense reading the code:

1) index.php redirects to EXT:install/Start/Install.php since typo3conf/LocalConfiguration.php does not exist yet.
2) The StepController is executed.
3) The StepController calls outputInstallToolNotEnabledMessageIfNeeded.
4) The ENABLE_INSTALL_TOOL file does not exist -> further execution is prevented.

Am I missing something somewhere?

#3 Updated by Markus Klein about 6 years ago

  • Target version deleted (6.2.0)

Just retested it.

My empty installation looks like this:

drwxrws---. 2 apache apache 4096 Oct 15 18:22 .
drwxr-xr-x. 6 root   root   4096 Oct 15 14:25 ..
lrwxrwxrwx. 1 root   apache   19 Oct 15 14:26 index.php -> typo3_src/index.php
lrwxrwxrwx. 1 root   apache   15 Oct 15 14:26 typo3 -> typo3_src/typo3
lrwxrwxrwx. 1 root   apache   12 Oct 15 14:25 typo3_src -> ../typo3git/

I navigate the browser to http://example.com/t3testinst/ and the first step of the installer shows up.

#4 Updated by Mathias Brodala about 6 years ago

I got it. I already have a typo3conf directory since I need to preset some settings as well as ship some extensions. Thus the install tool enable file check is actually performed by the AbstractController and bound to fail.

Do you see any way to circumvent this? The check could be changed to the LocalConfiguration.php instead since that one is essential too and indicates a not yet started installation.

I for myself can also instruct my virtual machine setup script to create the ENABLE_INSTALL_TOOL file upon first start but others might not have this option.

#5 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New

#6 Updated by Christian Kuhn almost 5 years ago

  • Status changed from New to Rejected

First install is only triggered if there is no typo3conf directory at all, and this is good this way.

If typo3conf exists, the installation is considered as "this was setup already", so it is not the "first (!) installation" anymore.

Get your deployment right: You either have a clean installation without anything, or a fully setup instance. There is nothing in between.

Also available in: Atom PDF