Bug #54120

Scheduler crashes after update on cleanup

Added by Christian no-lastname-given over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
-
Start date:
2013-12-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

After updating TYPO3 4.7 to latest bugfix version, the scheduler crashes all the time with the following error message:

    Fatal error: Call to a member function getExecutionTime() on a non-object in /var/www/bph/typo3_src-4.7.16/typo3/sysext/scheduler/class.tx_scheduler.php on line 113

The bug was introduced with that commit:

https://git.typo3.org/Packages/TYPO3.CMS.git/commitdiff/d361b2999c8ba8d1cdb218ead4f60ef1de9fe458

The $task variable in that case is in fact an integer and not an object, so just reverting would be fine (I guess that changed in the 6.x branch and the commit somehow made it into 4.x?).

#1

Updated by Markus Klein over 7 years ago

  • Status changed from New to Accepted
  • TYPO3 Version changed from 4.7 to 4.5
  • Is Regression changed from No to Yes

Yes, has to be reverted!

Easy to see: since 6.0 $task is reassigned the line above the change to be an object.

#2

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25846

#3

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25847

#4

Updated by Markus Klein over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF