Bug #54222

No user readable error message for missing database

Added by Christopher Hlubek almost 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-12-06
Due date:
% Done:

0%


Description

If a database is configured but not existing a request to the frontend causes a cryptic stacktrace:

Uncaught Exception in Flow
#1297759968: Exception while property mapping for target type "TYPO3\TYPO3CR\Domain\Model\Node", at property path "": The database which was specified in the configuration does not exist.
More information

TYPO3\Flow\Property\Exception thrown in file
/Users/hlubek/Dev/Neos/TYPO3-Neos-master/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/TYPO3_Flow_Property_PropertyMapper.php in line 119.
Reference code: 20131206112950f5b241

Nested Exception
#1049: The database which was specified in the configuration does not exist.
More information

TYPO3\Flow\Persistence\Doctrine\Exception\DatabaseConnectionException thrown in file
/Users/hlubek/Dev/Neos/TYPO3-Neos-master/Data/Temporary/Development/Cache/Code/Flow_Object_Classes/TYPO3_Flow_Persistence_Doctrine_Query.php in line 159.
Reference code: 201312061129503b3954

Go to the FORGE issue tracker and report the issue - if you think it is a bug!

It seems to be caused by the property mapping nesting the underlying DatabaseException which won't be displayed using a nice exception handler then.

Screenshot 2014-10-01 22.01.41.png View - new error message (64 KB) Jonas Renggli, 2014-10-01 22:02

History

#1 Updated by Jonas Renggli about 5 years ago

In Neos 1.1 a beautiful error message will be shown

Database Error
Sorry, we detected an error with your database. Check your logfiles in Data/Logs/* for more information.

You might want to configure or check your database configuration in the setup.

Go to setup

Also available in: Atom PDF