Bug #54379

Linking to the a page without workspace fails when reloading the page in the backend

Added by Christopher Hlubek almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
-
Start date:
2013-12-13
Due date:
% Done:

100%


Description

When clicking a link to page without the workspace identifier in the backend, a JS error occurs:

Uncaught TypeError: Cannot read property 'getSubject' of undefined

This is caused by the missing document metadata in the response.

I would expect an error notification and staying on the same page.

Associated revisions

Revision 0efc5250 (diff)
Added by Christopher Hlubek almost 6 years ago

[BUGFIX] Handle inline loading of pages without metadata correctly

Check the response for the page metainformation and show an error with
explanation. This can be improved by adding a link to the error message
that opens the requested location in a new tab in a follow-up.

Change-Id: I3234d053ade3c92448a9538e24731c6df8e83f8a
Fixes: #54379
Releases: master, 1.0
Reviewed-on: https://review.typo3.org/26393
Reviewed-by: Christopher Hlubek
Tested-by: Christopher Hlubek
Reviewed-by: Christian Mueller
Tested-by: Christian Mueller

Revision ed40c911 (diff)
Added by Christopher Hlubek almost 6 years ago

[BUGFIX] Handle inline loading of pages without metadata correctly

Check the response for the page metainformation and show an error with
explanation. This can be improved by adding a link to the error message
that opens the requested location in a new tab in a follow-up.

Change-Id: I3234d053ade3c92448a9538e24731c6df8e83f8a
Fixes: #54379
Releases: master, 1.0
Reviewed-on: https://review.typo3.org/26399
Reviewed-by: Christopher Hlubek
Tested-by: Christopher Hlubek

History

#1 Updated by Bastian Waidelich almost 6 years ago

Where are links without context rendered in the backend? Isn't that the issue?

#2 Updated by Christopher Hlubek almost 6 years ago

The logo on the Neos demo site is linked hard to the root page.

And yes, it should be linked correctly, but we should handle that error gracefully.

#3 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.Neos has been pushed to the review server.
It is available at https://review.typo3.org/26393

#4 Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch 1.0 of project Packages/TYPO3.Neos has been pushed to the review server.
It is available at https://review.typo3.org/26399

#5 Updated by Christopher Hlubek almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF