Bug #56980

Expanding inline elements in FlexForms loads forever

Added by Alexander Stehlik about 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-03-17
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Steps to reproduce:

  1. Add an inline element to your FlexForm configuration
  2. Load the form and add a record.
  3. Collapse the record
  4. Save the form
  5. Expand the record

The record will open correctly but the loading bar will never stop.

Example FlexForm field:

<settings.mysetting>
    <TCEforms>
        <label>Test</label>
        <config>
            <type>inline</type>
            <foreign_table>foreign_table</foreign_table>
            <foreign_field>parent_uid</foreign_field>
            <foreign_table_field>parent_table</foreign_table_field>
            <foreign_match_fields>
                <parent_field>parent_field</parent_field>
            </foreign_match_fields>
        </config>
    </TCEforms>
</settings.mysetting>

History

#1 Updated by Mathias Schreiber over 5 years ago

  • Description updated (diff)
  • Status changed from New to Resolved

fixed on master

#2 Updated by Alexander Stehlik over 5 years ago

Also seems to be fixed in the 6.2 branch, just did a quick test.

Thank you!

#3 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF