Feature #58213

add test for commandline tool expect

Added by Kay Strobach over 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Target version:
-
Start date:
2014-04-26
Due date:
% Done:

0%

Estimated time:

Description

it would be nice, if there would be a warning, if expect is missing.
Currently you get a simple:

Got exception "Deployment directory "/export/home/project/builds/testing" does not exist on node Staging" but rollback disabled. Stopping.

Related issues

Is duplicate of TYPO3.Surf - Bug #43366: Misleading error message if "expect" is not availableAccepted2012-11-28

Actions
#1

Updated by Kay Strobach about 7 years ago

Bash

    if hash expect 2>/dev/null; then
        exit 0
    else
        exit 1
    fi

should do it easily refering to https://stackoverflow.com/questions/592620/how-to-check-if-a-program-exists-from-a-bash-script

perhaps this should be made to a task, having a parameter which defines, for which binary tests should be executed ...

#2

Updated by Helmut Hummel over 5 years ago

  • Status changed from New to Accepted

Yes, a better error message would be nice

Development of TYPO3 Surf now moved to Github. If you think this is still relevant, please open a bug report or feature request here:

https://github.com/TYPO3/Surf

#3

Updated by Helmut Hummel over 5 years ago

  • Status changed from Accepted to Closed

closed as duplicate

Also available in: Atom PDF