Bug #59013

SystemLogger does not log additional arguments

Added by Carsten Bleicker over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Category:
Log
Target version:
-
Start date:
2014-05-21
Due date:
% Done:

0%

Estimated time:
PHP Version:
Has patch:
No
Complexity:

Description

The SystemLogger Interface supports additional arguemtns on exception logging.
But the dont appear in the logfile.

#1

Updated by Bastian Waidelich over 7 years ago

  • Category set to Log
  • Status changed from New to Needs Feedback
  • Assignee set to Bastian Waidelich

Hi Carsten,

can you please add more details, this is not reproducible.. For example: The router calls

$this->systemLogger->log('Router resolve(): Could not resolve a route for building an URI for the given route values.', LOG_WARNING, $routeValues);

which correctly creates

14-05-22 10:01:53  WARNING   Flow                 Router resolve(): Could not resolve a route for building an URI for the given route values.
    @action => someaction
    @controller => some\controller
    @package => some.package

in the log

#2

Updated by Carsten Bleicker over 7 years ago

hmm,
i used the exception logging. maybe this is the reason why its not reproducable?
$this->systemLogger->logException($noConverterFoundException, ['JobLabel' => $this->getLabel(), 'identifier' => $this->getIdentifier(), 'className' => $this->getClassName()]);

#3

Updated by Bastian Waidelich over 7 years ago

I just recreated the example:

$this->systemLogger->logException(new \TYPO3\Flow\Exception('Test Exception', 123), ['JobLabel' => 'someLabel', 'identifier' => 'someIdentifier', 'className' => 'someClassName']);

Creates

14-05-22 10:14:25  CRITICAL  Flow                 Uncaught exception #123: Test Exception - See also: 2014052210142421e9ae.txt
    JobLabel => someLabel
    identifier => someIdentifier
    className => someClassName

Can I close the issue?

#4

Updated by Carsten Bleicker over 7 years ago

Oh, sorry for this one.
I expected the additional info in the exception log itself :)
Please close it.

#5

Updated by Bastian Waidelich over 7 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF