Bug #59358

PackageManager does not work when being injected via Annotation

Added by Christian Loock over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-06-05
Due date:
% Done:

0%

Estimated time:

Description

Hi,

when I try to use the PackageManager, i discovered the following odd behaviour.

When I try to inject it via @Flow\Inject, any method called on it, will return no result.

When I use a injectPackageManager method, it works normally.


Related issues

Is duplicate of TYPO3.Flow - Bug #59357: Using the PackageManager directly instead of the Interface results in unexpected behaviorNew2014-06-05

Actions
#1

Updated by Bastian Waidelich over 7 years ago

  • Status changed from New to Closed

You reported this one minute after Marc reported #59357 ;)

Also available in: Atom PDF