Bug #59878

TYPO3\Flow\Core\Booting\Exception\SubProcessException thrown in file Scripts.php

Added by Andrew Isaak about 7 years ago. Updated about 7 years ago.

Status:
New
Priority:
Must have
Assignee:
-
Category:
- Error Handler Report -
Start date:
2014-06-25
Due date:
% Done:

0%

Estimated time:
1.00 h
PHP Version:
5.5
Has patch:
No
Complexity:

Description

When trying to run Neos 1.1.0 (extracted directly from the zip archive) on Windows (7 or 8 - tried both) using Xamp (or similar package), the following fatal error occurs. This is a critical bug.

Execution of subprocess failed with exit code 1 without any further output. (Please check your PHP error log for possible Fatal errors)
12 TYPO3\Flow\Core\Booting\Scripts::executeCommand("typo3.flow:core:compile", array|16|)

11 TYPO3\Flow\Core\Booting\Scripts::initializeProxyClasses(TYPO3\Flow\Core\Bootstrap)

10 call_user_func(array|2|, TYPO3\Flow\Core\Bootstrap)

9 TYPO3\Flow\Core\Booting\Step::__invoke(TYPO3\Flow\Core\Bootstrap)

8 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

7 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

6 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

5 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

4 TYPO3\Flow\Core\Booting\Sequence::invoke(TYPO3\Flow\Core\Bootstrap)

3 TYPO3\Flow\Http\RequestHandler::boot()

2 TYPO3\Flow\Http\RequestHandler::handleRequest()

1 TYPO3\Flow\Core\Bootstrap::run()

Please include more helpful information!


Related issues

Has duplicate TYPO3.Flow - Bug #59882: TYPO3\Flow\Core\Booting\Exception\SubProcessException thrown in file Scripts.phpClosed2014-06-25

Actions
#1

Updated by Andrew Isaak about 7 years ago

More information
TYPO3\Flow\Core\Booting\Exception\SubProcessException thrown in file
C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Scripts.php in line 528
.
Reference code: 20140625144517013cea

Go to the FORGE issue tracker and report the issue - if you think it is a bug!

12 TYPO3\Flow\Core\Booting\Scripts::executeCommand("typo3.flow:core:compile", array|16|)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Scripts.php:

00248: // The compile sub command will only be run if the code cache is completely empty:
00249: if ($objectConfigurationCache->has('allCompiledCodeUpToDate') === FALSE) {

00250: self::executeCommand('typo3.flow:core:compile', $settings);

00251: if (isset($settings['persistence']['doctrine']['enable']) && $settings['persistence']['doctrine']['enable'] === TRUE) {
00252: self::compileDoctrineProxies($bootstrap);

11 TYPO3\Flow\Core\Booting\Scripts::initializeProxyClasses(TYPO3\Flow\Core\Bootstrap)

10 call_user_func(array|2|, TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Step.php:

00047: */
00048: public function __invoke(\TYPO3\Flow\Core\Bootstrap $bootstrap) {

00049: call_user_func($this->callback, $bootstrap);

00050: }
00051:

9 TYPO3\Flow\Core\Booting\Step::__invoke(TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Sequence.php:

00099: $bootstrap->getSignalSlotDispatcher()->dispatch(CLASS, 'beforeInvokeStep', array($step, $this->identifier));
00100: $identifier = $step->getIdentifier();

00101: $step($bootstrap);

00102: $bootstrap->getSignalSlotDispatcher()->dispatch(CLASS, 'afterInvokeStep', array($step, $this->identifier));
00103: if (isset($this->steps[$identifier])) {

8 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Sequence.php:

00103: if (isset($this->steps[$identifier])) {
00104: foreach ($this->steps[$identifier] as $followingStep) {

00105: $this->invokeStep($followingStep, $bootstrap);

00106: }
00107: }

7 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Sequence.php:

00103: if (isset($this->steps[$identifier])) {
00104: foreach ($this->steps[$identifier] as $followingStep) {

00105: $this->invokeStep($followingStep, $bootstrap);

00106: }
00107: }

6 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Sequence.php:

00103: if (isset($this->steps[$identifier])) {
00104: foreach ($this->steps[$identifier] as $followingStep) {

00105: $this->invokeStep($followingStep, $bootstrap);

00106: }
00107: }

5 TYPO3\Flow\Core\Booting\Sequence::invokeStep(TYPO3\Flow\Core\Booting\Step, TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Booting\Sequence.php:

00083: if (isset($this->steps['start'])) {
00084: foreach ($this->steps['start'] as $step) {

00085: $this->invokeStep($step, $bootstrap);

00086: }
00087: }

4 TYPO3\Flow\Core\Booting\Sequence::invoke(TYPO3\Flow\Core\Bootstrap)

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Http\RequestHandler.php:

00158: protected function boot() {
00159: $sequence = $this->bootstrap->buildRuntimeSequence();

00160: $sequence->invoke($this->bootstrap);

00161: }
00162:

3 TYPO3\Flow\Http\RequestHandler::boot()

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Http\RequestHandler.php:

00114: $this->response = new Response();
00115:

00116: $this->boot();

00117: $this->resolveDependencies();
00118: $this->request->injectSettings($this->settings);

2 TYPO3\Flow\Http\RequestHandler::handleRequest()

C:\xampp\htdocs\neos\Packages\Framework\TYPO3.Flow\Classes\TYPO3\Flow\Core\Bootstrap.php:

00106:
00107: $this->activeRequestHandler = $this->resolveRequestHandler();

00108: $this->activeRequestHandler->handleRequest();

00109: }
00110:

1 TYPO3\Flow\Core\Bootstrap::run()

C:\xampp\htdocs\neos\Web\index.php:

00025: $context = getenv('FLOW_CONTEXT') ?: (getenv('REDIRECT_FLOW_CONTEXT') ?: 'Development');
00026: $bootstrap = new \TYPO3\Flow\Core\Bootstrap($context);

00027: $bootstrap->run();

#2

Updated by Andrew Isaak about 7 years ago

  • Assignee set to Robert Lemke
  • Target version set to 1.1.1

Hi Robert,

sorry to bother you, but this is a critical issue for Neos adoption,
as most people use Windows to try out Neos.

Best,
Andrew

#3

Updated by Andrew Isaak about 7 years ago

  • Assignee changed from Robert Lemke to Bastian Waidelich

Increasing php memory from 256 to 512 in php.ini did not solve the problem.

#4

Updated by Bastian Waidelich about 7 years ago

  • Assignee deleted (Bastian Waidelich)

Hi Andrew,

thanks for reporting, but please don't assign tickets to other people. To increase visibility use the mailing list or one of the mentioned channels on http://typo3.org/support/

Also make sure that your PHP development environment is setup correctly (e.g. PHP errors must not be suppressed)

Also available in: Atom PDF