Bug #60287

Server Team - Task #60284: Finishing after Gerrit and Redmine migration

Styling issues after Redmine migration

Added by Michael Stucki about 5 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-07-12
Due date:
2014-07-23
% Done:

0%


Description

The voting feature in Redmine is gone.

The related issues show wrong background colors for issue states, e.g. resolved is red

new has no colour (look at this post).

I assume these issues are somehow related to the migration.

(Reported by Lorenz Ulrich in #60284)

resolved.png View (1.51 KB) Michael Stucki, 2014-07-12 01:38


Related issues

Related to forge.typo3.org - Bug #60288: Text references are not working Closed 2014-07-12 2014-07-13
Related to forge.typo3.org - Bug #61567: Colors of related issues are displayed wrong Resolved 2014-09-13
Related to forge.typo3.org - Task #80999: Reintroduce green background for state "under review" Closed 2017-04-25
Related to forge.typo3.org - Bug #81033: Use a new Redmine theme Accepted 2017-04-27

History

#1 Updated by Michael Stucki about 5 years ago

  • Parent task set to #60284

#2 Updated by Steffen Gebert about 5 years ago

I think this was some customization in our installation. When I look [here](http://www.redmine.org/issues/17309) I see no colors.
Also the CSS that forge sends does not fit to the html, as the latter one doesn't contain a .status-X (X in {1..5}), which reflects the actual status.

#3 Updated by Steffen Gebert about 5 years ago

  • Status changed from New to Accepted

#4 Updated by Peter Niederlag about 5 years ago

  • Status changed from Accepted to Needs Feedback
  1. the voting feature is gone for now. Unfortunatly we could not find a version that is maintained so we decided to drop it. If someone has an idea or resources to bring it back, we'd be more than happy to get it back.
  2. styling issues, can someone please describe the problem in more details? Or did someone fix it meanwhile? to me the styling looks ok, resolved tickets show up in grey, new one in red.

#5 Updated by Michael Stucki almost 5 years ago

  • Due date set to 2014-07-23
  • Assignee set to Michael Stucki

#6 Updated by Peter Niederlag almost 5 years ago

referenced issues had a nice background color in Wikis indicating the status of the ticket

#7 Updated by Markus Klein almost 5 years ago

For the wiki it seems resolved to me, but not for related issues.
Example: https://forge.typo3.org/issues/36754 (everything is green ;-))

Regarding the voting feature: Honestly, +1 for not having it anymore. Reporters voted and wondered why nobody gave shit about it. As long as the votes have no meaning in regards to ticket priority, we should leave them off.

#8 Updated by Alexander Opitz almost 5 years ago

The color of the status of an related issue have the same color like the status of the issue themself.

It seams that the problem is that the <div> with relations is now inside the <div> of the issue and gets the status-x passed from parent.

#9 Updated by Michael Stucki over 2 years ago

  • Assignee deleted (Michael Stucki)

This is still partly broken after upgrading to Redmine 3.3.

We could drop the TYPO3 theme and start from scratch with a custom theme. Who wants to do that?

#10 Updated by Andreas Beutel about 2 years ago

  • Related to Task #80999: Reintroduce green background for state "under review" added

#11 Updated by Xavier Perseguers about 2 years ago

I could suggest you to have a look at this theme: http://www.abacusthemes.com/en/themes/subscription-office-blues

I bought it for 19€ for my own bug tracker and I'm quite happy with it. You could then think of customizing it, if you want to get back some TYPO3 feeling but at least you wouldn't loose much precious time reimplementing all they did

#12 Updated by Michael Stucki about 2 years ago

Hi Xavier!

thanks for this suggestion. We are also delighted by the Abacus theme. It looks really great!

The problem here is that it is closed source which contradicts with the open source infrastructure we're currently using. We would have to find a way to store it so that others cannot download it. Also, contributions to the theme (if needed) won't be possible (but that does not seem necessary anyway)...

#13 Updated by Michael Stucki about 2 years ago

Just to clarify: I'm not saying no to it, but we need to think about a solution for this...

#14 Updated by Michael Stucki about 2 years ago

  • Related to Bug #81033: Use a new Redmine theme added

#15 Updated by Bastian Bringenberg about 2 months ago

  • Status changed from Needs Feedback to Closed

Will not do.

Also available in: Atom PDF