Bug #6030

Router needlessly lowercases names of package, controller, action

Added by Karsten Dambekalns over 11 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Should have
Category:
MVC
Start date:
2010-01-14
Due date:
% Done:

100%

Estimated time:
PHP Version:
Has patch:
Complexity:

Description

Templates in Fluid need to be in a path whose parts have to be lowercased, which breaks consistency. That is caused by the Router applying strtolower() on a bunch of values in setControllerKeysAndFormat(). Furthermore some of those calls are double-whoppered, e.g. for the package key. Just check what happens in Request::setControllerPackageKey()...

#1

Updated by Karsten Dambekalns over 11 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Applied in changeset r3633.

Also available in: Atom PDF