Bug #61135

Indexed Search not indexing

Added by Samir Rachidi about 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2014-08-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Suddenly the search index was not working anymore and I tried to find the error. First, I thought it was a configuration mistake, but after some testing and reading the documentation etc. it was clear, that everything was configured fine. So i started some debugging and i found a strange bug:

In the file typo3/sysext/indexed_search/Classes/Indexer.php in the function

    public function hook_indexContent(&$pObj) {
...

there is the line 292:

$this->conf['mtime'] = $pObj->register['SYS_LASTCHANGED']

When I output the content of $pObj->register I can confirm, that no key 'SYS_LASTCHANGED' exists. Therefore, the Indexed Search extension tries to insert a NULL-value into the column 'mtime' in the index_phash table, but MySQL throws an error and the index_phash table stays empty!

I have insufficient knowledge about the internal processes of the typo3 core, but somehow the register-property of the TypoScriptFrontendController does not contain the 'SYS_LASTCHANGED' array-key. I thought, maybe this bug comes from an extension, but after removing all third party extensions, I assume it is a bug in the core, but i did not find the real culprit.

So, IMHO the best solution is:

$this->conf['mtime'] = ($pObj->register['SYS_LASTCHANGED'] !== NULL) ? $pObj->register['SYS_LASTCHANGED'] : $pObj->page['SYS_LASTCHANGED'];

Maybe somebody knows, why $pObj->register has no 'SYS_LASTCHANGED'-key and can fix the root of the problem. Until then, I would like to make a pull request on this change, but I just do not know how to do this.

It is a Typo3 6.0.13, but we also updated the system to Typo3 6.2 and even there some pages were not indexed and i assume that it was the same problem.

#1

Updated by Markus Klein about 7 years ago

Hi!

Thanks for your report.
We do not use the github-style development process, hence we have no "pull-requests".
You can find all information about contributing here: http://wiki.typo3.org/CWT

It is indeed strange that the register is not set.
Unfortunately indexed_search is a "forgotten child", so there're almost no changes between 4.x and 6.2.
It would definitely need some motivated minds that give the extension a nudge.

#2

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32350

#3

Updated by Samir Rachidi about 7 years ago

Hi,

thanks for the good hint! I made a change request, but the only thing missing: I think this change should be propagated in many Typo3 Version, at least 6.0, 6.1 and 6.2. I only pushed it into the 6.0 Version. Maybe it also makes sense to push in into the 4.7.

Should i just push it in any of the different branches or is there some automatism? Or should i just wait for a discussion about this change in the gerit review?

Just asking, because it is my first change request ;-)

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32355

#5

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32355

#6

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32355

#7

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32601

#8

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32602

#9

Updated by Samir Rachidi about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF