Bug #61494

LegacyClassesForIde not loaded?

Added by David Bruchmann over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-09-10
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

calling the class t3lib_arrayBrowser (by realUrl) I get the error

Fatal error: Class 't3lib_arrayBrowser' not found in /var/www/typo3_src-6.2.4/typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4364

I think the class still should be loaded by the script LegacyClassesForIde.php where it's written

/**
 * @deprecated since 6.0 will be removed in 7.0
 */
class t3lib_arrayBrowser extends \TYPO3\CMS\Lowlevel\Utility\ArrayBrowser {}

In this case the class is called by the realUrl-Info-modul, that's the way how to reproduce.

related to #61493

History

#1 Updated by Markus Klein over 5 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (next-patchlevel)

Hi!

Please ask in the forums (e.g. German or English) for better support as this seems to be not a Core issue and we do not provide support via the bug tracker.
Thank you.

#2 Updated by Alexander Opitz about 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF