Bug #65345

Cannot set select multiple conditionally

Added by Mathias Brodala over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Category:
Fluid
Target version:
-
Start date:
2015-02-25
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Currently one cannot set the multiple attribute of the SelectViewHelper conditionally like this:

<f:form.select property="foo" options="{options}" multiple="{multiple}"/>

As soon as the multiple attribute is used, it is rendered in any case with whatever value was passed. (Thus if you pass true as suggested currently, you get an invalid multiple="true".

This should be fixed by converting multiple into a boolean argument.

Associated revisions

Revision 711462be (diff)
Added by Mathias Brodala about 4 years ago

[BUGFIX] Evaluate select multiple attribute as boolean

The "multiple" attribute should not be rendered blindly with whatever was
passed. It should be evaluated as boolean argument instead.

This is a non-breaking change since Fluid converts any string which is not
empty or not case-insensitive "false" to boolean TRUE.

Resolves: #65345
Releases: master
Change-Id: I426b0446ae31c1efd81de8068ecd1e647c01a18d
Reviewed-on: https://review.typo3.org/37238
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Tested-by: Bjoern Jacob <>
Reviewed-by: Bjoern Jacob <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37238

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37238

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37238

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37238

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37238

#6 Updated by Mathias Schreiber about 4 years ago

  • Target version deleted (next-patchlevel)

#7 Updated by Gerrit Code Review about 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/37238

#8 Updated by Mathias Brodala about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#9 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF