Bug #65433

Invalid back path of ImageViewHelper in TYPO3 backend

Added by Oliver Hader about 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2015-03-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

If rendering an image in the TYPO3 backend, the regular case is to prepend "../" to an URI with the assumption that the HTTP request was handled by typo3/backend.php. For the page module for instance, the request points to typo3/sysext/cms/layout/db_layout.php, thus the back path trick does not work anymore.

To overcome that behavior the absolute path shall be used in stead by determining TYPO3_SITE_PATH.
For that case that some custom processing relies on "../" this change might be breaking.

#1

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37407

#2

Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37408

#3

Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/37408

#4

Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF