Bug #67406

Form sysext detected as broken in install tool

Added by Sebastian Michaelsen over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-06-10
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

With the big change to the TYPO3 autoloading (https://github.com/TYPO3/TYPO3.CMS/commit/ec2b4f4266af7bc93e301ad4735464f958a6d1bf) the form system extension is detected as broken by the install tool.

http://shots.michaelsen.io/HYEa

History

#1 Updated by Markus Klein over 4 years ago

Can't reproduce this.

Did your run `composer update` and did you clear all caches in Install Tool after fetching the source?

#2 Updated by Markus Klein over 4 years ago

  • Status changed from New to Needs Feedback
  • Assignee deleted (Helmut Hummel)

#3 Updated by Helmut Hummel over 4 years ago

I also cannot reproduce this

#4 Updated by Helmut Hummel over 4 years ago

  • Status changed from Needs Feedback to Rejected

As far as I understand Sebastian on Slack, he uses a composer distribution without class loading information in root composer.json

With the new class loader change this has become mandatory.

We might improve the situation here, but for now this is how it is.

specify a autoload section in your root composer.json like that:

    "autoload": {
        "psr-4": {
            "TYPO3\\CMS\\About\\": "typo3_src/typo3/sysext/about/Classes/",
            "TYPO3\\CMS\\Aboutmodules\\": "typo3_src/typo3/sysext/aboutmodules/Classes/",
            "TYPO3\\CMS\\Filelist\\": "typo3_src/typo3/sysext/filelist/Classes/",
            "TYPO3\\CMS\\Form\\": "typo3_src/typo3/sysext/form/Classes/",
            "TYPO3\\CMS\\Impexp\\": "typo3_src/typo3/sysext/impexp/Classes/",
            "TYPO3\\CMS\\Rsaauth\\": "typo3_src/typo3/sysext/rsaauth/Classes/",
            "TYPO3\\CMS\\Rtehtmlarea\\": "typo3_src/typo3/sysext/rtehtmlarea/Classes/",
            "TYPO3\\CMS\\SysNote\\": "typo3_src/typo3/sysext/sys_note/Classes/",
            "TYPO3\\CMS\\T3editor\\": "typo3_src/typo3/sysext/t3editor/Classes/",
            "TYPO3\\CMS\\T3skin\\": "typo3_src/typo3/sysext/t3skin/Classes/",
            "TYPO3\\CMS\\CssStyledContent\\": "typo3/sysext/css_styled_content/Classes/" 
        },
        "classmap": ["typo3conf/ext/realurl/"]
    },

Also available in: Atom PDF