Bug #7039

if ViewHelper: conditions always true

Added by Nikolas Berger over 11 years ago. Updated almost 11 years ago.

Status:
Rejected
Priority:
-- undefined --
Assignee:
-
Category:
ViewHelpers
Target version:
-
Start date:
2010-03-28
Due date:
% Done:

0%

Estimated time:
Has patch:

Description

My code:

{foo.bar} 

<f:if condition="{foo.bar} == test1"><f:then> test1 </f:then></f:if>
<f:if condition="{foo.bar} == test2"><f:then> test2 </f:then></f:if>
<f:if condition="{foo.bar} == test3"><f:then> test3</f:then></f:if>

The output is:

test2

test1 
test2 
test3

But I expected this result:

test2

test2 

Is my syntax wrong?


Related issues

Is duplicate of TYPO3.Fluid - Task #6757: support literal strings in boolean argumentsResolved2010-03-10

Actions
#1

Updated by Peter Niederlag over 11 years ago

Please have a look at the documentation, f:if currently can't handle literals/strings. :-<

#2

Updated by Nikolas Berger over 11 years ago

Peter Niederlag wrote:

Please have a look at the documentation, f:if currently can't handle literals/strings. :-<

Is that the solution? http://forge.typo3.org/issues/show/6757

#3

Updated by Sebastian Kurfuerst over 11 years ago

  • Status changed from New to Rejected

as stated by Peter, Fluid does not support strings right now.

Greets,
Sebastian

Also available in: Atom PDF