Bug #77877

NewContentElementController removes wizard elements

Added by Nicole Cordes over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2016-09-07
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The NewContentElementController can't handle configuration like mod.wizards.newContentElement.wizardItems.common.show = *, name

This can happen if you install extensions which both change the newContentElement configuration.

Tested with bootstrap_package 7.0.2 which adds configuration mod.wizards.newContentElement.wizardItems.common.show = * and attached extension which sets mod.wizards.newContentElement.wizardItems.common.show := addToList(name)

mask_example_0.1.0_201609071439.zip (3.98 KB) Nicole Cordes, 2016-09-07 15:56

Associated revisions

Revision 0c436836 (diff)
Added by Nicole Cordes over 3 years ago

[BUGFIX] Correct show configuration in newContentElement wizard

All elements should be shown if the asterisk is part of the show
configuration. Due to different configuration possibilities it can happen
that the asterisk is not the only value of this configuration.

Resolves: #77877
Releases: master, 7.6, 6.2
Change-Id: I5439f76ec40788cdaed14012e7b83b18e2b56d18
Reviewed-on: https://review.typo3.org/49875
Tested-by: TYPO3com <>
Reviewed-by: Peter Linzenkirchner <>
Tested-by: Peter Linzenkirchner <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 693de54e (diff)
Added by Nicole Cordes over 3 years ago

[BUGFIX] Correct show configuration in newContentElement wizard

All elements should be shown if the asterisk is part of the show
configuration. Due to different configuration possibilities it can happen
that the asterisk is not the only value of this configuration.

Resolves: #77877
Releases: master, 7.6, 6.2
Change-Id: I5439f76ec40788cdaed14012e7b83b18e2b56d18
Reviewed-on: https://review.typo3.org/49883
Tested-by: TYPO3com <>
Reviewed-by: Markus Sommer <>
Tested-by: Markus Sommer <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 5b6f9fce (diff)
Added by Nicole Cordes over 3 years ago

[BUGFIX] Correct show configuration in newContentElement wizard

All elements should be shown if the asterisk is part of the show
configuration. Due to different configuration possibilities it can happen
that the asterisk is not the only value of this configuration.

Resolves: #77877
Releases: master, 7.6, 6.2
Change-Id: I5439f76ec40788cdaed14012e7b83b18e2b56d18
Reviewed-on: https://review.typo3.org/49951
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49875

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49883

#3 Updated by Nicole Cordes over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49951

#5 Updated by Nicole Cordes over 3 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF