Bug #78017

T3d upload fails if "Overwrite existing files" is unchecked

Added by Nicole Cordes over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2016-09-20
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I want to upload a t3d file to be able to import it in my current master installation. This fails as long as the option "Overwrite existing files" is unchecked. Because fluid generates an empty hidden field for each checkbox, an empty value is transmitted.

On DuplicationBehavior::cast an exception is thrown because of the empty value.

Associated revisions

Revision 94d740c2 (diff)
Added by Nicole Cordes over 3 years ago

[BUGFIX] Ensure proper conflictMode on t3d upload

The overwriteExistingFiles argument in ImportExportController can't be
cast to \TYPO3\CMS\Core\Resource\DuplicationBehavior due to an empty
value. This patch ensures a correct conflict mode which can be cast.

Resolves: #78017
Related: #77136
Releases: master
Change-Id: Ib55191bc2f6368d2322270315083f80ee13fe45d
Reviewed-on: https://review.typo3.org/49984
Reviewed-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49984

#2 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49984

#3 Updated by Nicole Cordes over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF