Bug #78250

Database analyzer can't create table with dbal in native mode

Added by Nicole Cordes over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Must have
Assignee:
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2016-10-11
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Following steps should be necessary to reproduce the problem:

1) activate dbal
2) install news extension

expected result:
news should be installed and database tables should be generated

actual result:
no tables are generated

Go to Install Tool and run the database analyzer. it will show the necessary tables for news. Trying to execute those gives error message "Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'C' at line 1".

After having a look into dbal I found the problem. \TYPO3\CMS\Dbal\Database\DatabaseConnection::admin_query expects the CREATETABLE type to return an array. Instead a string was return but $string0 was taken as sql query.


Related issues

Related to TYPO3 Core - Task #68401: Consolidate SqlParser.php Closed 2015-07-20

Associated revisions

Revision 3b7e6042 (diff)
Added by Nicole Cordes over 1 year ago

[BUGFIX] Handle different result types in dbal

Due to multiple SQL compilers the return type is mixed between strings
and arrays. To be able to run both the
\TYPO3\CMS\Dbal\Database\DatabaseConnection::admin_query should care
about arrays.

Resolves: #78250
Releases: 7.6
Change-Id: Ib9b3e8cb3d98e4556257331a720aeaa49db0b2cd
Reviewed-on: https://review.typo3.org/50189
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50189

#2 Updated by Nicole Cordes over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF