Bug #78703

Updating Http_Request2 to 2.3.0 causes DocumentationService->fetchDocument to fail

Added by Claus Due about 2 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-11-15
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Reason for failure is a grave incompatibility with SSLv2 on libcurl on at least OSX, likely other *NIX systems as well.

Switching to GeneralUtility::getUrl() solves the issue completely.

Associated revisions

Revision 400e2002 (diff)
Added by Claus Due about 2 years ago

[BUGFIX] Use GeneralUtility::getUrl in DocumentationService->fetchDocument

This avoids issues with frequent incompatibilities with SSLv2
in libcurl.

Change-Id: I7eae2d266da2d11cc809603974f73f4a9c089467
Resolves: #78703
Releases: 7.6
Reviewed-on: https://review.typo3.org/50663
Tested-by: TYPO3com <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision a61499fd (diff)
Added by Claus Due about 2 years ago

[BUGFIX] Use GeneralUtility::getUrl in DocumentationService->fetchDocument

This avoids issues with redirects due to the change to https of
docs.typo3.org

Change-Id: I7eae2d266da2d11cc809603974f73f4a9c089467
Resolves: #78703
Releases: 7.6, 6.2
Reviewed-on: https://review.typo3.org/50709
Reviewed-by: Claus Due <>
Tested-by: Claus Due <>
Tested-by: TYPO3com <>
Tested-by: Stephan Gro├čberndt <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50663

#2 Updated by Anonymous about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Gerrit Code Review about 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50709

#4 Updated by Anonymous about 2 years ago

  • Status changed from Under Review to Resolved

#5 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF