Bug #78778

Update composer dependencies for 7.6

Added by Helmut Hummel almost 2 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-11-23
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The composer dependencies, which are locked down in composer.lock are completely outdated
and do not reflect the installed state when doing a composer install of typo3/cms

Besides that, there is a dependency to a dev version of psr/log which isn't required and potentially harmful.

Associated revisions

Revision 2d333ed9 (diff)
Added by Helmut Hummel almost 2 years ago

[TASK] Update composer dependencies for local builds

Update the external libraries to reflect the state of
composer installations.

Use that opportunity to pin psr/log to a stable version
instead of using the master branch (which is equivalent anyway)

Resolves: #78778
Releases: 7.6
Change-Id: Ia85c09c640ca7b0c4231ef214d60a43b7adfa284
Reviewed-on: https://review.typo3.org/50755
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Peter Foerger <>
Tested-by: Peter Foerger <>
Reviewed-by: Markus Sommer <>
Tested-by: Markus Sommer <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50755

#2 Updated by Anonymous almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF