Bug #78798

EXT:Form mail and wizard issues

Added by Philipp Idler over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2016-11-25
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Yesterday I patched a TYPO3 6.2.12 installation to latest 6.2.29.

I mentioned some issues when using the form's wizard and receiving mails:

  • Editing field names and values doesn't work anymore. After saving and reopening, input fields in wizard are empty or filled with numbers
  • Changing sender's or receiver's email address doesn't work either
  • Radio buttons and checkbox values get suffixed with their internal value (number) in receiver's mail

I checked this behaviour in two different TYPO3 installations with a newly created form element.
Static template is included on root page and there are no other options for tx_form set.

Seems like there is something heavily broken

History

#1 Updated by Stephan Großberndt over 3 years ago

  • Status changed from New to Needs Feedback

Could you please share an example configuration of a form with the relevant broken fields? Thanks!

#2 Updated by Philipp Idler over 3 years ago

method = post
prefix = tx_form
confirmation = 
postProcessor {
    1 = mail
    1 {
        recipientEmail = xxx@yyy.de
        subject = Anmeldung
        messages {
            success = TEXT
            success {
                value = <p>Vielen Dank für Ihre Anmeldung! Sie erhalten in Kürze eine schriftliche Anmeldebestätigung sowie eine Rechnung.</p>
            }
        }
    }
}
10 = TEXTBLOCK
10 {
    class = content-textblock
    content = Hiermit melde ich mich verbindlich für den XXX an:
}
20 = RADIOGROUP
20 {
    class = fieldset-subgroup
    legend {
        value = Adresse:
    }
    name = Adresse
    10 = RADIO
    10 {
        label {
            value = Dienstliche Adresse
        }
    }
    20 = RADIO
    20 {
        label {
            value = Private Adresse
        }
    }
}
30 = RADIOGROUP
30 {
    class = fieldset-subgroup
    legend {
        value = Anrede
    }
    name = Anrede
    10 = RADIO
    10 {
        label {
            value = Frau
        }
    }
    20 = RADIO
    20 {
        label {
            value = Herr
        }
    }
}
40 = TEXTLINE
40 {
    name = Vorname
    label {
        value = Vorname: *
    }
}
50 = TEXTLINE
50 {
    name = Nachname
    label {
        value = Nachname: *
    }
}
60 = TEXTLINE
60 {
    name = Institution
    label {
        value = Institution:
    }
}
70 = TEXTLINE
70 {
    name = Strasse_Nr
    label {
        value = Straße, Nr.: *
    }
}
80 = TEXTLINE
80 {
    name = PLZ_Ort
    label {
        value = PLZ, Ort: *
    }
}
90 = TEXTAREA
90 {
    cols = 40
    rows = 5
    name = Abweichende_Rechnungsadresse
    label {
        value = Falls Sie die Rechnung an eine abweichende Adresse wünschen, geben Sie hier bitte den genauen Rechnungsnehmer an
    }
}
100 = TEXTLINE
100 {
    name = Telefon
    label {
        value = Telefon:
    }
}
110 = TEXTLINE
110 {
    name = EMail
    label {
        value = E-Mail: *
    }
}
120 = RADIOGROUP
120 {
    class = fieldset-subgroup
    legend {
        value = Mitgliedschaft: *
    }
    name = Mitgliedschaft
    10 = RADIO
    10 {
        label {
            value = Ich bin nicht Mitglied
        }
    }
    20 = RADIO
    20 {
        label {
            value = Ich bin Einzelmitglied
        }
    }
    30 = RADIO
    30 {
        label {
            value = Ich bin Vertreter eines korporativen Mitgliedes
        }
    }
}
130 = TEXTLINE
130 {
    name = Name_des_korporativen_Mitglieds
    label {
        value = Name des korporativen Mitglieds:
    }
}
140 = TEXTLINE
140 {
    name = Mitgliedsnummer
    label {
        value = Mitgliedsnummer:
    }
}
150 = CHECKBOX
150 {
    name = Checkbox Storno
    value = ja
    label {
        value = Ich habe die Stornobedingungen* gelesen.
    }
}
160 = SUBMIT
160 {
    name = 16
    value = Anmeldung senden
}
rules {
    1 = required
    1 {
        breakOnError = 0
        showMessage = 
        message = *
        error = Dies ist ein Pflichtfeld
        element = Vorname
    }
    2 = required
    2 {
        breakOnError = 0
        showMessage = 
        message = *
        error = Dies ist ein Pflichtfeld
        element = Nachname
    }
    3 = required
    3 {
        breakOnError = 0
        showMessage = 
        message = *
        error = Dies ist ein Pflichtfeld
        element = Strasse_Nr
    }
    4 = required
    4 {
        breakOnError = 0
        showMessage = 
        message = *
        error = Dies ist ein Pflichtfeld
        element = PLZ_Ort
    }
    5 = required
    5 {
        breakOnError = 0
        showMessage = 
        message = *
        error = Dies ist ein Pflichtfeld
        element = EMail
    }
    6 = required
    6 {
        breakOnError = 0
        showMessage = 
        message = *
        error = Dies ist ein Pflichtfeld
        element = Mitgliedschaft
    }
}

#3 Updated by Ralf Zimmermann about 3 years ago

I can not reproduce this issue for now.

I tested your form declaration and a newly created form.
Editing values / saving it / reopening it works for me with a newly created TYPO3 v6.2.29 instance.
I tested labels / select options / checkbox options / radio button options / postProcessor settings.
The mail values looks also good.

The only difference i can see at this time is that i create a new TYPO3 installation and you perform an update.
But i have currently not enough time to setup such a scenario.

#4 Updated by Philipp Idler about 3 years ago

Thanks for your investigations!
Now it's my turn to test my conf with a clean installation... I will report my experiences.

#5 Updated by Philipp Idler about 3 years ago

I can reproduce this issue on a clean installation of 6.2.29.
Did you save and close the form's wizard after your add some fields?
The numbers in the form fields do only show up after closing and reopening the wizard.

#6 Updated by Ralf Zimmermann about 3 years ago

Yes, i closed and reopened the wizard.

Ralf Zimmermann wrote:

Editing values / saving it / reopening it works for me with a newly created TYPO3 v6.2.29 instance.

How do you install your TYPO3 instance?
Do you have some non system extensions installed?
Do you use a site package or a distribution?

#7 Updated by Philipp Idler about 3 years ago

Ralf Zimmermann wrote:

How do you install your TYPO3 instance?
Do you have some non system extensions installed?
Do you use a site package or a distribution?

My test setup is completely out of the box: No extensions, no template. Man, that's weird.
I don't believe that it has something to do with PHP version...

Got that behavouir on three installations for now.

#8 Updated by Ralf Zimmermann about 3 years ago

Ok, i try to investigate further.

#9 Updated by Philipp Idler about 3 years ago

I've made another test on a different webhoster with an older php version (5.4.). Same behavoir here:
After I save the wizard, close and open it again, I get number instead of my previously defined attribute names and receiver's email is empty in TS.

I've even compared all changes in tx_form coming with TYPO3 6.2.12 (from which I updated) and current 6.2.29 but I can't figure out why this is happening.
Seems like all field names get converted to unique numbers by saving the wizard.

#10 Updated by Bjoern Jacob about 3 years ago

  • Assignee set to Philipp Idler

Since the problem cannot be reproduced and 6.2 is nearly dead (only priority bugfixes) I would recommend updating to 7.6. Philipp, maybe update the installation on a test system to 7.6 and see if the problem still occurs. If it still happens, let's see if you can provice a test system which we can access as well.

#11 Updated by Bjoern Jacob about 3 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Philipp Idler)

I am closing this issue. 6.2 is nearly dead. Version 8 is on its way. Upgrade to v8 and enjoy the new form editor and all the things.

Also available in: Atom PDF