Bug #83

phpCR tests need cleanup

Added by Robert Lemke almost 12 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Must have
Start date:
Due date:
% Done:

0%


Description

There are a few issues with the phpCR tests. Among them:

  • test case class names don't comply with the naming rules: phpCR_SomeTest instead of T3_phpCR_SomeTest
  • @package annotations are mostly wrong, referring to phpCRJackrabbit
  • some test methods are static
  • some methods are not documented / lack doc comments

In general, some tests look more like functional tests than like unit tests - but I might be wrong with that.

History

#1 Updated by Karsten Dambekalns almost 12 years ago

  • Status changed from New to Accepted

#2 Updated by Karsten Dambekalns almost 12 years ago

  • Status changed from Accepted to Closed
  • Sprint set to duplicate

This is more or less a duplicate of #49. I copied the relevant parts of this ticket there and resolve this one as duplicate.

#3 Updated by Robert Lemke over 11 years ago

  • Target version deleted (1)

Also available in: Atom PDF