Bug #83112

Fix invalid type hints in EXT:form's file upload converter

Added by Oliver Hader about 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2017-11-27
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Due to invalid PHP type hints updating a previously uploaded file reference in a mail form fails.

Associated revisions

Revision a6849252 (diff)
Added by Oliver Hader almost 2 years ago

[BUGFIX] Fix invalid type hints in EXT:form's file upload converter

Due to invalid PHP type hints updating a previously uploaded file
reference in a mail form fails in the frontend.

Resolves: #83112
Releases: master, 8.7
Change-Id: Ibf98267a60f076b5654fb0d0d9181a4caeed49b3
Reviewed-on: https://review.typo3.org/54784
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 2abb8579 (diff)
Added by Oliver Hader almost 2 years ago

[BUGFIX] Fix invalid type hints in EXT:form's file upload converter

Due to invalid PHP type hints updating a previously uploaded file
reference in a mail form fails in the frontend.

Resolves: #83112
Releases: master, 8.7
Change-Id: Ibf98267a60f076b5654fb0d0d9181a4caeed49b3
Reviewed-on: https://review.typo3.org/54985
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54784

#2 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54784

#3 Updated by Gerrit Code Review about 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54784

#4 Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54784

#5 Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54784

#6 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54985

#7 Updated by Oliver Hader almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF