Bug #83246

TCA "check" eval "maximumRecordsChecked*" not implemented anymore

Added by Mathias Brodala over 2 years ago. Updated 3 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2017-12-07
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The two eval options maximumRecordsChecked and maximumRecordsCheckedInPid mentioned in the docs for TCA type check are not implemented anymore. This might have been dropped with the FormEngine refactor.

History

#1 Updated by Mathias Schreiber over 2 years ago

  • Is Regression changed from Yes to No

Hi Mathias,

I checked the code and it behaves exactly the same since 6.2.
Are you sure we have an issue here?

#2 Updated by Georg Ringer 3 months ago

  • Status changed from New to Rejected

Hi Mathias,

the code is still there and works, example is in sys_file_storage with the default checkbox. If set on a 2nd record, I get the msg

1: Could not activate checkbox for field "Ist Standardspeicher?". A total of 1 record(s) can have this checkbox activated. Uncheck other records first in order to activate the checkbox of this record.

therefore I am closing this issue, feel free to reopen if still valid.

#3 Updated by Mathias Brodala 3 months ago

Georg Ringer wrote:

the code is still there and works, example is in sys_file_storage with the default checkbox.

Can you point out the exact location in code where this is implemented? Searching the code for these two identifiers yields nothing except the original commit which introduced this feature.

Also available in: Atom PDF