Bug #8540

Call to undefined method F3\\Fluid\\View\\TemplateView::parseTemplate()

Added by Michael Schams almost 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-06-29
Due date:
% Done:

0%

Estimated time:
Has patch:

Description

PHP Fatal error after changes in r4654 but also in r4656:

[Tue Jun 29 00:45:30 2010] [error] [client xx.xx.xx.xx] PHP Fatal error:
Call to undefined method F3\\Fluid\\View\\TemplateView::parseTemplate()
in /home/flow3/www/FLOW3-subversion/trunk/Packages/Framework/Fluid/Classes/View/AbstractTemplateView.php on line 236
#1

Updated by Michael Schams almost 12 years ago

Problem occurs if you have Partials in your templates, for example:

<f:render partial="PartialName" />

If fluid template files do not contain partials to render, problem does not appear.

#2

Updated by Karsten Dambekalns almost 12 years ago

  • Project changed from TYPO3.Flow to TYPO3.Fluid
#3

Updated by Sebastian Kurfuerst almost 12 years ago

Hey,

can you upload your template please? Here, everything seems to work with the exact same setup.

Greets,
Sebastian

#4

Updated by Michael Schams almost 12 years ago

Hmmm... we are unable to reproduce this issue again. In (newer) FLOW3/Fluid versions, Partials are working. Also tested with FLOW3-1.0.0-alpha10 package.

I am happy to suspend this ticket or close it as "not reproducible".

#5

Updated by Sebastian Kurfuerst almost 12 years ago

  • Status changed from New to Closed

great that it is solved :-)

Greets,
Sebastian

Also available in: Atom PDF