Bug #86108

Missing translations in file jquery.dataTables.js

Added by Florian Rival about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Target version:
-
Start date:
2018-09-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There are some translations missing in the file :

typo3/sysext/core/Resources/Public/JavaScript/Contrib/jquery.dataTables.js

Example :

"No matching records found",
"Loading...",
"Processing...",
"Search:"

#1

Updated by Wouter Wolters about 2 years ago

  • Status changed from New to Needs Feedback

This is a 3rd party JavaScript library... nothing TYPO3 can do about that.

Can you check if you can create a ticket in their repository?

#2

Updated by Florian Rival about 2 years ago

I think the problem comes from Typo3 because translations are available with jquery.datatables but I think there's some initialization missing somewhere to tell jequery.datatables which language to use.

Have a look here : [[https://datatables.net/plug-ins/i18n/]] : translation have to be loaded with an Ajax request or at initialisation.

#3

Updated by Frank Naegler about 2 years ago

The core currently use the datatables only in the scheduler for sorting the columns.
I guess we will remove datatables in v10. Where did you have the problem of missing labels?

#4

Updated by Florian Rival about 2 years ago

I looked closely to the problem and it appears that it doesn't come from Typo3 core but from a third part extension.
You can close this issue.

#5

Updated by Wouter Wolters about 2 years ago

  • Status changed from Needs Feedback to Closed

Closed as requested.

Also available in: Atom PDF