Bug #86135

[Still] missing translation on core changes v9.x

Added by Preben Rather Sørensen over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Must have
Target version:
-
Start date:
2018-09-04
Due date:
% Done:

100%

Estimated time:

Description

The translation server (translation.typo3.org) still don't update some labels in core on v9.x.

E.g. site.identifier and site_language.typo3Language

Seems like the sync is broken.


Files

backend-l10n-de.zip (2.91 KB) backend-l10n-de.zip Current DE-File for Backend-Extension Kay Röseler, 2018-10-05 13:00
86135_missingTranslationsExampleDe.png (258 KB) 86135_missingTranslationsExampleDe.png Joerg Kummer, 2018-10-05 14:41

Related issues

Related to Translation Team - Bug #82174: Missing translation on Core changesResolvedXavier Perseguers2017-08-22

Actions
Related to TYPO3 Core - Bug #85351: TYPO3 out of sync on translation serverClosedXavier Perseguers2018-06-22

Actions
#1

Updated by Preben Rather Sørensen over 3 years ago

  • Related to Bug #82174: Missing translation on Core changes added
#2

Updated by Preben Rather Sørensen over 3 years ago

  • Related to Bug #85351: TYPO3 out of sync on translation server added
#3

Updated by Xavier Perseguers over 3 years ago

  • Status changed from New to Needs Feedback

Missing information

Missing information in this bug report:

  • site.identifier and site_language.typo3Language are part of:
    • EXT:backend/Resources/Private/Language/siteconfiguration_fieldinformation.xlf (t3:id = 1522923345)
    • EXT:backend/Resources/Private/Language/locallang_siteconfiguratoin_tca.xlf (t3:id = 1522785604)

Taking German as target test language, this means:

Analysis

Conclusion

I cannot reproduce with the provided information.

#4

Updated by Preben Rather Sørensen over 3 years ago

I find all the same on translation server as well. Point is, that the same labels don't show up in the TYPO3 v9.x installation when updating the language pack - sorry for not making that clear.

#5

Updated by Stephan Großberndt about 3 years ago

  • Description updated (diff)
#6

Updated by Joerg Kummer about 3 years ago

Translations on translation server seems to be correct, but the locallang files, I expected to be downloaded to my typo3conf/l10n folder are missing.
In this case for danish:
/typo3conf/l10n/da/backend/Resources/Private/Language/da.locallang_siteconfiguration_tca.xlf
and
/typo3conf/l10n/da/backend/Resources/Private/Language/da.siteconfiguration_fieldinformation.xlf

Currently there are following 17 locallang files in TYPO3 sysext/backend/Resources/Private/Language/:
  • locallang.xlf
  • locallang_alt_doc.xlf
  • locallang_db_new_content_el.xlf
  • locallang_layout.xlf
  • locallang_login.xlf
  • locallang_mod.xlf
  • locallang_mod_help_cshmanual.xlf
  • locallang_pages_new.xlf
  • locallang_pages_new_csh.xlf
  • locallang_pages_sort.xlf
  • locallang_pages_sort_csh.xlf
  • locallang_show_rechis.xlf
  • locallang_siteconfiguration.xlf
  • locallang_siteconfiguration_module.xlf
  • locallang_siteconfiguration_tca.xlf
  • locallang_view_help.xlf
  • siteconfiguration_fieldinformation.xlf
But only 3 locallang files in typo3conf/l10n/da/backend/Resources/Private/Language/:
  • da.locallang_mod_help_cshmanual.xlf
  • da.locallang_siteconfiguration.xlf
  • da.locallang_siteconfiguration_module.xlf

It looks like an amount of files, are not available or synced. Maybe also for other core extensions.

#7

Updated by Thomas Löffler about 3 years ago

I checked the files and the sync on the TER server.

The sync is working, all translation ZIP files in the backend folder were changed on October 2nd at 0:50.
The ZIP files include exactly these files as mentioned in the previous comment.
The ZIP files on the translation server in the folder /var/www/translation.typo3.org/public/l10n_ter/b/a/backend-l10n have the same filesize as on the TER server.

I can't search deeper, it must be something between the ZIP files on the translation server and the translation tool.

#8

Updated by Kay Röseler about 3 years ago

Thomas Löffler wrote:

The ZIP files include exactly these files as mentioned in the previous comment.

This is correct. When downloading the current language selection for German (started 5 minutes ago), you will get from the Translation Server the attached zip-file containing only the DE-files specified in comment #note-6. All others from the core extension "backend" are missing, but are almost completely translated according to the translation server.

#9

Updated by Joerg Kummer about 3 years ago

Thats why in TYPO3 v9.5.0 currently some items are not shown in translated words in choosen language. In TYPO3 7 and 8 it is correct shown.
Can someone change status from Needs Feedback to a more productive status?

#10

Updated by Xavier Perseguers about 3 years ago

  • Status changed from Needs Feedback to Accepted
  • Assignee set to Xavier Perseguers

Will have a look

#11

Updated by Xavier Perseguers about 3 years ago

Problem stems from file /srv/pootle/po/TYPO3.core.backend/.typo3/TYPO3v9.filemapping which contains only 3 lines:

locallang.1415814872.xlf Resources/Private/Language/locallang_mod_help_cshmanual.xlf
locallang.1522771784.xlf Resources/Private/Language/locallang_siteconfiguration_module.xlf
locallang.1522780424.xlf Resources/Private/Language/locallang_siteconfiguration.xlf
#12

Updated by Gerrit Code Review about 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58670

#13

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58670

#14

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58670

#15

Updated by Xavier Perseguers about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF