Bug #86714

Upgrade Wizard in Install Tool shows HTML tag <warning>

Added by Peter Kraume almost 3 years ago. Updated over 1 year ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2018-10-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:
Needs Decision

Description

If a upgrade wizard fails in the Install Tool, this error message is show:

Update failed!
<warning>The extension adminpanel can not be downloaded since Composer is used for package management. Please require this extension as package via Composer: "composer require typo3/cms-adminpanel:^9.2"</warning>

I'm not sure about the intended behaviour but I assume that the HTML tag <warning> should be replaced in a later step.

The the affected code is in typo3/sysext/install/Classes/Updates/AbstractDownloadExtensionUpdate.php, line 113.

In the same file, in lines 94 and 99 there is the HTML tag <error> used. But I haven't tested if these messages are affected as well.


Files

installtool.png (34.2 KB) installtool.png Peter Kraume, 2018-10-22 23:43

Also available in: Atom PDF