Bug #883

install error

Added by Stefano Cecere over 12 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Could have
Category:
Installation Issues
Target version:
-
Start date:
2008-06-27
Due date:
2008-06-30
% Done:

100%

Estimated time:
8.00 h

Description

hallo
i'm trying DEV3 for the first time with Eclipse (3.3.2 downloaded yesterday from http://downloads.zend.com/pdt/all-in-one/)
and i'm having this error installing it:

(i attach two screenshots)

stefano


Files

Picture_5.png (51.6 KB) Picture_5.png Stefano Cecere, 2008-06-27 05:49
Picture_6.png (34 KB) Picture_6.png Stefano Cecere, 2008-06-27 05:49
Picture_7.png (96.9 KB) Picture_7.png Stefano Cecere, 2008-06-28 01:57
Picture_8.png (29.5 KB) Picture_8.png Stefano Cecere, 2008-06-28 01:57
stefano_eclipse_configuration.txt (115 KB) stefano_eclipse_configuration.txt my Eclipse configuration Stefano Cecere, 2008-06-28 10:17
#1

Updated by Sebastian Böttger over 12 years ago

  • Due date set to 2008-06-30
  • Category set to Installation Issues
  • Status changed from New to Accepted
  • Assignee set to David Bruehlmeier
  • % Done changed from 0 to 70
  • Estimated time changed from 0.00 h to 1.00 h

feature.xml got wrong version number. fixed and now testing

#2

Updated by David Bruehlmeier over 12 years ago

This bug cannot be reproduced with the same Eclipse Installation, but on Windows XP.

It is true that the version number of the plugin org.typo3.forge.dev3 does not match with the version number in the feature. Maybe the Mac-related code reacts differently to this situation than the XP-related code?

I have now corrected the version number issue. Please test again, using the latest code from the update site (http://www.dev3.org/update/). Please install using the Eclipse Update Manager.

#3

Updated by Stefano Cecere over 12 years ago

thanks david

installing it from http://www.dev3.org/update/ it works!

stefano

#4

Updated by David Bruehlmeier over 12 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 70 to 100
#5

Updated by Stefano Cecere over 12 years ago

i'm sorry but it isn't resolved..

see in the screenshots what happens when i select DEV3 in the preferences, or Create new package..

thanks
stefano

ps: eclipse 3.3.2 Build id: M20080221-1800 on os x 10.5.3 Intel

stefano

#6

Updated by David Bruehlmeier over 12 years ago

  • Status changed from Resolved to Accepted
  • % Done changed from 100 to 50
#7

Updated by David Bruehlmeier over 12 years ago

Hi Stefano,

can you please attach the configuration details of your Eclipse installation (Help > About Eclipse Platform > Configuration Details).

Thanks!
Dave

#8

Updated by Stefano Cecere over 12 years ago

ciao David
here it is my Eclipse configuration (attached file)
s

#9

Updated by David Bruehlmeier over 12 years ago

Hi Stefano,

you have Java version 5 installed, but I am compiling with version 6. The error in the screenshot Picture_7.png usually occurs from differente JRE versions.

Can you please update your JRE and test again? I think the JRE for Mac can be downloaded here:

http://developer.apple.com/java/download/

Regards, Dave

#10

Updated by Stefano Cecere over 12 years ago

Java 6 for osx 10.5.2 is only for 64 bit intel CPUs right now...

i see if i can find Java 6 for "still normal" 32bit machines...

thanks
s

#11

Updated by patrick lischka over 12 years ago

hi everybody,

i can confirm these bug. I have the same problems with the installation on my mac.

regards
patrick

#12

Updated by David Bruehlmeier over 12 years ago

  • Target version changed from 0.2 to 1.0
#13

Updated by David Bruehlmeier over 12 years ago

  • Target version deleted (1.0)
#14

Updated by patrick lischka over 12 years ago

the bug still exist in version 1.0.0

is there anybody out there who runs dev3 on a mac?

regards
patrick

#15

Updated by David Bruehlmeier over 12 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 50 to 100
  • Estimated time changed from 1.00 h to 8.00 h

This bug should be resolved with the new version 1.0.1 (available from the update site: http://www.dev3.org/update/). In this version, I have backported the features from Java6 to Java5, since Java5 is not yet available for Mac.

Also available in: Atom PDF