Bug #88347

Workspaces preview of translated language

Added by mosa mosa over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2019-05-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Can’t preview my translated language while inside my workspace, it only shows the default language. The link is also the same for the preview button.


Files

workspace link.png (440 KB) workspace link.png mosa mosa, 2019-05-14 07:44
88347-placeholder-not-hidden.patch (1.1 KB) 88347-placeholder-not-hidden.patch Sebastian Michaelsen, 2020-04-15 08:16

Related issues

Related to TYPO3 Core - Bug #91662: Workspace Preview without Backend login not working anymoreClosedBenni Mack2020-06-16

Actions
#1

Updated by Susanne Moog 11 months ago

  • Sprint Focus set to On Location Sprint
#2

Updated by Sebastian Michaelsen 8 months ago

I can reproduce this problem both in TYPO3 8.7 and on master (10.4.0-dev).

Steps to reproduce:

  • Have an installation with a Workspace and at least one non-default language.
  • Set up a page with content in default language
  • Switch to your workspace
  • Translate the page content into a new language
  • Preview in that language -> default language will be shown

My findings so far:

  • In the above scenario when creating the translation, two records are created: A placeholder in the LIVE WS and an Offline record.
  • $GLOBALS['TCA']['tt_content']['ctrl']['hideAtCopy'] is 1 by default which causes the placeholder to be hidden
  • If the placeholder is not hidden, the preview works.
Workaround:
  • Configure $GLOBALS['TCA']['tt_content']['ctrl']['hideAtCopy'] to 0.
  • For our project I created a patch that always sets hidden = 0 for the placeholder record right in the DataHandler. I'm not sure this is the clean solution. I'm attaching my patch file for 8.7 maybe it is helpful for others.
#4

Updated by Christian Kuhn 4 months ago

  • Related to Bug #91662: Workspace Preview without Backend login not working anymore added
#5

Updated by Christian Kuhn 4 months ago

Played around on this for a while.

Reproducible in v9 but fixed in v10 and master. In v9 I was unable to preview the translated page / content element that exists in the workspace only. That is no problem in v10/master as soon as the admin panel settings 'show hidden content' and 'show hidden pages' are set. That behavior is identical to live.

I didn't nail which patch fixed that, but #91662 is a good candidate, it has been merged after Sebastians comment.

I'll close the issue for now since I think it's resolved. Please ping us if we missed something.

#6

Updated by Christian Kuhn 4 months ago

  • Status changed from New to Closed

Also available in: Atom PDF