Bug #90998

Composer downgrades packages while updating from TYPO3 10.0 to TYPO3 10.3

Added by Dieter Porth 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
-
Start date:
2020-04-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

What have i done?
I installed a TYPO3-Version with the following stepe and got the following screenshot.

1. console: composer create-project "typo3/cms-base-distribution:^10" source
2. console: composer req bk2k/bootstrap-package
3. Edit Composer.json (change all entries "~10.0.0" to "^10.0.0"
4. console: composer update

Bug or wished?
The screenshot shows, that there are two components, which are downgraded, while i Try to update TYPO3.

Is this wished or is there perhaps a bug in an composer-definition?
The downgrade irritated me a little bit.


Files

#1

Updated by Christian Eßl 8 months ago

  • Guzzle is downgraded, because the current version afaik still has problems with resolving domains that contain umlauts on some systems (often reported on mittwald servers)
    https://forge.typo3.org/issues/90940
  • phpdocumentor/type-resolver should have been updated to 1.1.0 already in master. (In TYPO3 10.3 it is still 0.7.2)
#2

Updated by Riccardo De Contardi 8 months ago

  • Category set to composer
#3

Updated by Riccardo De Contardi 8 months ago

  • Status changed from New to Closed

I think that this issue can be closed - works like expected.

If you think that this is the wrong decision or I have misunderstood, please reopen it or ping me and I'll do.

Thank you.

Also available in: Atom PDF