Bug #91502

CLI command backend:lock uses wrong path

Added by Georg Ringer about 1 year ago. Updated 10 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
CLI
Target version:
-
Start date:
2020-05-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
path lock cli
Complexity:
Is Regression:
Sprint Focus:

Description

Using TYPO3 with traditional setup, so using the tar.gz (not tested with composer mode) will use wrong path to generate the LOCK file.

The command ./typo3_src/typo3/sysext/core/bin/typo3 backend:lock will create the output

 [OK] Wrote lock file to "/app/web/typo3_src/typo3conf/LOCK_BACKEND".

but the path is wrong as it must be /app/web/typo3conf/LOCK_BACKEND"

#1

Updated by Georg Ringer about 1 year ago

  • Category set to CLI
  • Tags changed from path lock to path lock cli
#2

Updated by Georg Ringer about 1 year ago

  • Status changed from Accepted to Rejected

sorry, was stupid me

#3

Updated by Christian Hackl 11 months ago

I run into the same problem - and the file is not created at the path mentioned at the output of the command.
So I think it would be better if there is a desition like:

TYPO3\CMS\Backend\Command\LockBackendCommand::class - line 67

if (is_file($lockFile)) {
    $io->success($output);
} else {
    $io->warning('Can't create file: ' . $lockFile);
}
#4

Updated by Benni Mack 10 months ago

Interestingly enough, this is a mis-use of the binary, as the root path cannot be determined, when executing the binary from a symlinked location. I did the following:

cd typo3_src/
cd typo3/sysext/core/bin/

./typo3

and I only see information as TYPO3 would not have been installed yet. Why is that? Well, that's because TYPO3 cannot determine the root path anymore, if you're not using the base folder.

So, in general, I'd like to find out, where this is documented to call "./typo3_src/typo3/sysext/core/bin/typo3", as we really need to clarify this.

Also available in: Atom PDF